Project

General

Profile

Story #8371

Develop Ability to Host Multiple Nodes from a Single Installation of GMN Web App

Added by Monica Ihli over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
2018-02-19
Due date:
% Done:

100%

Story Points:
Sprint:

Description

Problem Statement:

For some business models, a single organization may host and otherwise manage content for multiple source repositories or producers of science data. Examples might include a consortial or aggregator arrangement. In such cases it may be most appropriate for each of the source data providers to maintain their respective identities, while still having their participation in DataONE managed by the central entity. This means that a single entity should be able to host and manage multiple DataONE member nodes. The problem is that GMN presently only supports hosting a single Member Node per installation of the web app. The only way to meet the above stated needs is for the one entity to setup multiple web servers, creating a situation of additional costs and barriers.

Proposed Solution:

The solution is to modify GMN so that multiple member nodes can be hosted from a single installation of the web application.

Notes on the basic strategy is as follows:
* The CN recognize and interact with MN through the node's baseURL.
* A BaseURL and all of the content on the node is tied to the Node doc. GMN needs to be able to serve up different content for different baseURLs.
* This would be facilitated through Apache's ability to serve content for multiple hosts from a single web server.
* WRT application itself, would be implemented with vendor specific extension that allows the create() call to add a field specifying which Node doc goes with the particular object.
* Also adds a layer of abstraction to the database.


Related issues

Related to Member Nodes - MNDeployment #8035: IEDA_EarthChem Library (Interdisciplinary Earth Data Alliance) Operational 2018-01-24

History

#1 Updated by Monica Ihli over 4 years ago

  • Related to MNDeployment #8035: IEDA_EarthChem Library (Interdisciplinary Earth Data Alliance) added

#2 Updated by Monica Ihli over 4 years ago

  • Description updated (diff)

#3 Updated by Dave Vieglais over 3 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)