Project

General

Profile

Bug #7948

An UnAuthorization exception happened when the CN synchronized the objects with sid from tARD mn

Added by Jing Tao over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
d1_synchronization
Target version:
Start date:
2016-12-06
Due date:
% Done:

100%

Milestone:
None
Product Version:
*
Story Points:
Sprint:

Description

Dave saw an UnAuthorization exception happened when the CN synchronized the objects with sid from tARD mn. We tracked down it caused by a method in V2TransferObjectTask. In that method, it will check the submitter in the given system metadata if has the change permission in the header of sid. We need the new code to check if the rights holder has the change permission when the submitter doesn't have the permission. It works.


Related issues

Duplicated by Infrastructure - Bug #8024: Submitter Being Checked During SeriesId Validation within V2TransferObjectTask Rejected 2017-02-20

History

#1 Updated by Jing Tao over 5 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

The fixed code was committed to both trunk and 2.3 branch. The d1_synchronization, d1_processdaemon and dataone-cn-processdaemon 2.3 branch were increased the version to 2.3.1

#2 Updated by Rob Nahf over 5 years ago

  • Duplicated by Bug #8024: Submitter Being Checked During SeriesId Validation within V2TransferObjectTask added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)