Project

General

Profile

Bug #7665

NullPointer exception if NodeReplicationPolicy does contain maxObjectSize

Added by Robert Waltz over 8 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
d1_cn_noderegistry
Start date:
2016-02-25
Due date:
% Done:

30%

Story Points:
Sprint:

Description

org.dataone.cn.ldap.NodeAccess, mapNodeModificationItemList, line 867

/* NodeReplicationPolicy elements and attributes */
if (node.getNodeReplicationPolicy() != null) {
NodeReplicationPolicy rp = node.getNodeReplicationPolicy();

            modificationItemList.addAll
            .
            .
            .

check for null before proceeding with updating any of the optional attributes of NodeReplicationPolicy


Related issues

Related to Infrastructure - Bug #7379: GMN could not save Node document with null NodeReplicationPolicy.max size property Closed 2015-09-23

History

#1 Updated by Robert Waltz about 8 years ago

  • Description updated (diff)

#2 Updated by Robert Waltz about 8 years ago

  • Target version set to CCI-2.4.0

#3 Updated by Robert Waltz about 8 years ago

  • Description updated (diff)

#4 Updated by Robert Waltz about 8 years ago

  • Assignee changed from Robert Waltz to Rob Nahf

#5 Updated by Rob Nahf almost 8 years ago

  • Related to Bug #7379: GMN could not save Node document with null NodeReplicationPolicy.max size property added

#6 Updated by Rob Nahf almost 8 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 30

seems to be a duplicate of #7379, but maybe this is a different but related issue.

#7 Updated by Rob Nahf over 7 years ago

  • Status changed from In Progress to Rejected

a duplicate of another ticket, already fixed.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)