Project

General

Profile

Task #2842

Story #2840: Implement morpho to use Dataone API

Design and implment the APIs for morpho to connect Dataone nodes

Added by Jing Tao over 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2012-06-01
Due date:
% Done:

100%

Milestone:
CCI-1.0.0
Product Version:
*
Story Points:
Sprint:

Description

We haven't decided if we will get rid of metacat apis from morpho. But i am think we can add a new abstract plugin which charges the communications between morpho and remote repositories. We may names the plugin "RemoteRepository Plugin". We needs a carefully designed APIs for it. The developer can decide to implement the plugin interface by use metacat APIs, dataone APIs or something else.

History

#1 Updated by Rob Nahf over 9 years ago

Following the existing DataStoreInterface, it would be straightforward to implement a DataONEDataStore, just as there is MetacatDataStore.

Turning that into a plugin and designing the plugin seems to be the bulk of the design work here.

#2 Updated by Jing Tao over 9 years ago

The problem is that DataStoreInterface doesn't encapsulate the all codes which connect the metacat server. Metacate code is scattered around the entire morpho source code. So we need to redesign the API. Of course, we can borrow some APIs from DataStoreInterface.

#3 Updated by Dave Vieglais over 9 years ago

  • Target version changed from Sprint-2012.37-Block.5.3 to Sprint-2012.41-Block.6.1

#4 Updated by Ben Leinfelder over 9 years ago

  • Target version changed from Sprint-2012.41-Block.6.1 to Sprint-2012.44-Block.6.2

#5 Updated by Chris Jones about 9 years ago

  • Target version changed from Sprint-2012.44-Block.6.2 to Sprint-2012.50-Block.6.4

#6 Updated by Ben Leinfelder almost 9 years ago

  • Target version changed from Sprint-2012.50-Block.6.4 to 2013.10-Block.2.1

#7 Updated by Ben Leinfelder almost 9 years ago

  • Status changed from New to Closed
  • translation missing: en.field_remaining_hours set to 0.0

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)