Project

General

Profile

Task #2327

Story #1906: Review, revise, and update architecture documentation

CNAuthorization.setRightsHolder() - Returns empty ObjectList

Added by Roger Dahl almost 10 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2012-02-13
Due date:
% Done:

0%

Milestone:
CCI-1.0.0
Product Version:
*
Story Points:
Sprint:

Description

I tested CNAuthorization.setRightsHolder() by calling it on an existing PID with an unknown owner. Expected result was a NotAuthorized exception. Instead, received an empty ObjectList (which should not be returned from setRightsHolder() even on success. I didn't test setRightsHolder() with other parameters.

DEBUG operation: GET /cn/v1/object?count=1&start=0
12/02/12 23:37:37 DEBUG headers: {'Charset': 'utf-8', 'Accept': 'text/xml', 'User-Agent': 'pyd1/1.0.0 +http://dataone.org/'}

ServiceFailure: name: ServiceFailure
errorCode: 500
detailCode: 0
description: Node responded with a valid status code but failed to include the expected Content-Type
Status code: 200
Content-Type: text/xml;charset=UTF-8

traceInformation: <?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="/cn/xslt/dataone.types.v1.xsl"?>

History

#1 Updated by Roger Dahl almost 10 years ago

  • Status changed from New to Rejected

This bug was caused by there not being any objects on the CN.

#2 Updated by Dave Vieglais about 7 years ago

  • Target version set to Maintenance Backlog

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)