Project

General

Profile

Bug #1505

Metacat incorrectly formats node registry information

Added by Robert Waltz almost 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Metacat
Target version:
Start date:
2011-04-13
Due date:
% Done:

100%

Milestone:
2011-Block-2
Product Version:
*
Story Points:
Sprint:

Description

Teragrid assigned the following values to metacat.properties file:

dataone.coordinatingNodeBaseURL=http://cn.dataone.org
dataone.memberNodeId=d1tg
dataone.nodeName=TeraGrid
dataone.nodeType=mn
dataone.nodeDescription=TeraGrid Production Member node running Metacat

However, the resulting nodeList produced by hitting the baseURL for D1 services reported the following:

<?xml version="1.0" encoding="UTF-8"?>


d1tg
TeraGrid -- WAR version WARVERSION
TeraGrid Production Member node running Metacat
d1tg/knb/d1/

/d1:nodeList

Name is concatenated with information that should go in the description field, and the baseURL assumes the identifier is significant. It should be assigning baseurl from server.name (assuming it is still a fully qualified domain server name), server.httpPort, application.context and the d1 service stub


Related issues

Related to Infrastructure - Task #1390: baseurl in metcat /nodes response incorrect Closed 2011-03-01

History

#1 Updated by Matthew Jones almost 11 years ago

  • Assignee set to Chris Jones
  • Target version set to Sprint-2011.16-Block.2

I think Chris already knows about this -- he worked on it last week, and I think is planning a change for next week when he returns. I'll assign this to him to see if its a duplicate of an existing ticket, or whether it should just get fixed here.

#2 Updated by Dave Vieglais over 10 years ago

  • Target version changed from Sprint-2011.16-Block.2 to Sprint-2011.17-Block.3
  • Position set to 1

#3 Updated by Chris Jones over 10 years ago

  • Status changed from New to Closed

Duplicate of https://redmine.dataone.org/issues/1390 which is now resolved.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)