Project

General

Profile

Bug #8821

Object doi:10.18739/A2610VR7Z fails to index on CN

Added by Bryce Mecum over 2 years ago. Updated over 2 years ago.

Status:
New
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
2019-06-18
Due date:
% Done:

0%

Milestone:
None
Product Version:
*
Story Points:
Sprint:

Description

I noticed https://search.dataone.org/cn/v2/meta/doi:10.18739/A2610VR7Z isn't present in the search index and asked about it on DataONEOrg #ci Slack channel. Chris noted that no no task was in the index queue for the PID. He tried to force a reindex which failed. He couldn't find a log entry indicating why it failed so someone needs to look into what's going on. It occurs to me that whatever bug is affecting this Object may have affected more Objects so a second part of fixing this bug should probably be doing some housekeeping or an audit of some kind to make sure the search index isn't missing more content.

History

#1 Updated by Bryce Mecum over 2 years ago

  • Assignee set to Jing Tao

#2 Updated by Bryce Mecum over 2 years ago

From Chris:

It definitely was submitted to the queue and processed, but for some reason the status was set to FAILED

#3 Updated by Jing Tao over 2 years ago

Somehow the Hazelcast objectPath map didn't have its information. I wrote a piece of java code to put the information for this object into the objectPath map. Then reindexed it again. It worked.

https://cn.dataone.org/cn/v2/query/solr/?q=id:%22doi:10.18739/A2610VR7Z%22

We need to figure out why it was missed from the map.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)