Project

General

Profile

Task #7891

Story #6625: Requirement of Java 1.8 for Dataone V2

remove postgres and java version dependencies from cn-buildout scripts

Added by Rob Nahf over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
d1_cn_buildout
Target version:
Start date:
2016-09-15
Due date:
% Done:

100%

Milestone:
None
Product Version:
*
Story Points:
Sprint:

Description

PG_CONF is a path with 9.1 hardcoded (4 projects)

JDK_DIRS is a property in dataone-cn-processdaemon, dataone-cn-index, dataone-cn-monitor

dataone-cn-os-core defines JAVA_SECURITY, JAVA_KEYSTORE, JAVA_SECURITY_EXT_DIR as version dependent paths
it also defines the worker.java_home as a version dependent path (in usr/shar/dataone-cn-os-core/debian/worker.properties)

dataone-solr /var/solr/bin/solr and solr.cmd also reference java 1.7

History

#1 Updated by Dave Vieglais over 3 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)