Project

General

Profile

Task #7829

Map rendering of spatial coordinates is wonky

Added by Laura Moyers almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
MetacatUI
Target version:
-
Start date:
2016-06-15
Due date:
% Done:

100%

Story Points:
Sprint:

Description

DFC in sandbox is exhibiting some odd behavior in the metadata view of search results for geographic coverage. See this as an example: https://search-sandbox.test.dataone.org/#view/11333/1855168. Note there are no values displayed for Bounding Coordinates, and the map is displaying Thailand. Lisa says that these are the bounding coordinates in the metadata for this package: northlimit=36.95317078; westlimit=-84.74267578; southlimit=32.81350327; eastlimit=-79.69732666/dcterms:spatial

It seems like DFC's spatial info has previously rendered as expected in search results, but in my cursory review of their content, I can't find one that does now.

Here's an example of another DCX MN (tDAR) whose search results display as expected. https://search-sandbox.test.dataone.org/#view/doi:10.6067:XCV848765_meta

Can you help us figure out if Lisa needs to tweak her metadata build, or if there has been a change in the rendering rules in sandbox?

History

#1 Updated by Mark Servilla almost 5 years ago

I have confirmed that DFC coordinates are correct in a generalized spatial context: Southeastern United States; see spatial output from the following Solr query: https://cn-sandbox.test.dataone.org/cn/v1/query/solr/?start=0&rows=10&q=id%3A11333%2F1851122

37.73539
33.59572
-75.94259
-81.03685

#2 Updated by Laura Moyers almost 5 years ago

More info: we think that, perhaps, the problem is in the DCX rendering of the map data.

In sandbox, if you query DFC MN content, the map rendering for (overall) search results is as expected (all in the SE US). Maybe that map rendering is coming from SOLR data. If you look at the search results for a single data package, the map rendering is wonky (in Thailand). Maybe that map rendering is coming from DCX data.

Is this possible?

#3 Updated by Lauren Walker almost 5 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
  • translation missing: en.field_remaining_hours set to 0.0

Fixed

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)