Project

General

Profile

Bug #7118

Count query parameter not limiting results on cn logs

Added by Jing Tao over 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
d1_identity_manager
Start date:
2015-05-18
Due date:
% Done:

100%

Story Points:
Sprint:

Description

Problem:
When running a query (in this case on accounts), the count parameter isn't being used.
These two queries return the same number of results (a lot more than 3).
https://cn-ucsb-1.dataone.org/cn/v1/accounts
https://cn-ucsb-1.dataone.org/cn/v1/accounts?start=0&count=3

How to reproduce:
I originally saw this by running through MultipartCNode.getLogRecords() from CNCoreV1IT's testGetLogRecords_dateFiltering() method, but the queries above work too.

Details:
In the standup meeting, we talked about the possibility that this is a recent bug introduced to the dev or sandbox environments, but I tried it in the production environment in the links above, so it looks like it made it in there too.

History

#1 Updated by Jing Tao over 6 years ago

  • Assignee changed from Peter Slaughter to Rob Nahf

#2 Updated by Rob Nahf over 6 years ago

  • Category set to d1_log_aggregation

the implementation is at https://repository.dataone.org/software/cicore/trunk/d1_identity_manager/src/main/java/org/dataone/service/cn/impl/v2/CNIdentityLDAPImpl.java

it does not do anything with the start or count parameters:

// TODO: use query and start/count params
@Override
public SubjectInfo listSubjects(Session session, String query, String status, Integer start,
Integer count) throws ServiceFailure, InvalidToken, NotAuthorized,
NotImplemented {

#3 Updated by Skye Roseboom over 6 years ago

  • Target version changed from CCI-1.5.2 to CCI-1.5.3

#4 Updated by Robert Waltz over 6 years ago

  • Category changed from d1_log_aggregation to d1_identity_manager
  • Project changed from Log Reporting to CN REST

This appears to be about d1 identity rather than log Aggregation.

#5 Updated by Dave Vieglais almost 6 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)