Project

General

Profile

Bug #6838

Count query parameter not limiting results on Accounts

Added by Andrei Buium almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
d1_identity_manager
Start date:
2015-02-03
Due date:
% Done:

100%

Story Points:
Sprint:

Description

Problem:
When running a query (in this case on accounts), the count parameter isn't being used.
These two queries return the same number of results (a lot more than 3).
https://cn-ucsb-1.dataone.org/cn/v1/accounts
https://cn-ucsb-1.dataone.org/cn/v1/accounts?start=0&count=3

How to reproduce:
I originally saw this by running through MultipartCNode.getLogRecords() from CNCoreV1IT's testGetLogRecords_dateFiltering() method, but the queries above work too.

Details:
In the standup meeting, we talked about the possibility that this is a recent bug introduced to the dev or sandbox environments, but I tried it in the production environment in the links above, so it looks like it made it in there too.

History

#1 Updated by Dave Vieglais over 6 years ago

  • Target version set to CCI-1.5.2
  • Assignee set to Jing Tao

#2 Updated by Dave Vieglais over 6 years ago

  • Tracker changed from Task to Bug

#3 Updated by Jing Tao over 6 years ago

  • Assignee changed from Jing Tao to Robert Waltz

I believe Robert is a better person than I to handle this bug.

#4 Updated by Jing Tao over 6 years ago

  • Subject changed from Count query parameter not limiting results to Count query parameter not limiting results on Accounts

#5 Updated by Jing Tao over 6 years ago

  • Assignee changed from Robert Waltz to Jing Tao

#6 Updated by Jing Tao over 6 years ago

  • Category changed from d1_cn_service to d1_identity_manager

#7 Updated by Jing Tao over 6 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

The code was committed to both trunk and D1_IDENTITY_MANAGER_v1.2 branch.

Andrei tested it and it worked for him.

#8 Updated by Skye Roseboom over 6 years ago

  • Target version changed from CCI-1.5.2 to CCI-1.5.3

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)