Project

General

Profile

Bug #6779

Metacat "hazelcast synchronization" does not emit a log message indicating the process has completed

Added by Dave Vieglais over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Metacat
Target version:
Start date:
2015-01-27
Due date:
% Done:

100%

Milestone:
None
Product Version:
*
Story Points:
Sprint:

Description

When running -forced replication- "hazelcast synchronization" in metacat, there is no log message to indicate that the process has finished. This should be corrected so that operators and services can reliably determine when the process completes.


Related issues

Related to Infrastructure - Bug #6773: PID Discrepancy on production CNs Closed 2015-01-26

History

#1 Updated by Dave Vieglais over 5 years ago

  • Related to Bug #6773: PID Discrepancy on production CNs added

#2 Updated by Dave Vieglais over 5 years ago

  • Subject changed from Metacat forced replication does not emit a log message indicating the process has completed to Metacat "hazelcast synchronization" does not emit a log message indicating the process has completed
  • Description updated (diff)

Updated description - the issue is about hazelcast synchronization rather than the metacat "forced replication"

#3 Updated by Jing Tao over 5 years ago

  • Status changed from New to In Progress

In the HazelcastService class, the log message to indicate the start and end of synchronization was added. It sets the warn level.

#4 Updated by Jing Tao over 5 years ago

  • % Done changed from 0 to 50
  • Status changed from In Progress to Testing

#5 Updated by Jing Tao over 5 years ago

  • % Done changed from 50 to 100
  • Status changed from Testing to Closed

#6 Updated by Jing Tao over 5 years ago

Installed the branch on cn-sandobx and asked Rober to test it. He confirmed that the issue was fixed.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)