Project

General

Profile

Bug #5311

MultipartRequestResolver leaking resources (open file handles)

Added by Rob Nahf over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
d1_common_java
Target version:
Start date:
2014-05-02
Due date:
2014-05-10
% Done:

100%

Milestone:
None
Product Version:
*
Story Points:
Sprint:

Description

the method resolveMultipart opens a FileOutputStream but does not use or close. Looks like leftover statement that forgot to be removed when refactoring.
(Bug introduced in r3147 on 1/27/2011)

Not sure how many releases of common_java this includes, but definitely impacts the CN, and may be the cause of the file descriptor issue on the CN that led to refactoring libclient to proactively close idle connections, and cache input streams in client memory to avoid resource leaks.


Related issues

Related to Infrastructure - Task #4474: create new tag release of d1_common_java Closed 2014-04-17
Related to Java Client - Task #3057: retest CLOSE_WAIT issue once the lib client is complete. In Progress 2012-07-09
Related to Infrastructure - Bug #2211: Use of d1_libclient_java may lead to open file descriptors Closed 2012-01-19

History

#1 Updated by Rob Nahf over 8 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

commented out the offending line in trunk, and in 1.2 branch.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)