Project

General

Profile

Task #4643

Enable indexing of archived content

Added by Dave Vieglais almost 8 years ago. Updated almost 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Skye Roseboom
Category:
d1_indexer
Target version:
Start date:
2014-03-26
Due date:
% Done:

0%

Milestone:
None
Product Version:
1.2.6
Story Points:
Sprint:

Description

Enabling indexing of archived content enables determination of the amount of content available in DataONE over time to be readily determined. This is not currently possible with CN.listObjects as the slice is against the date system metadata is modified rather than the date that content is added. It is not currently possible to use the search index for this as archived content is not included in the index.

This goal of this task is to enable indexing of archived content and add a property to the SOLR schema for an archived attribute, which would be a boolean that is False if the content is not archived, and True if archived.

Default searches should be for content where the archived flag is False. This will ensure query behavior remains consistent following the change to the schema and content is reindexed.

History

#1 Updated by Skye Roseboom almost 8 years ago

  • Parent task deleted (#4461)

#2 Updated by Dave Vieglais almost 8 years ago

  • Status changed from New to Rejected
  • translation missing: en.field_remaining_hours set to 0.0

After evaluating potential impacts to behavior, this task is being rejected, and will be further considered as a separate activity.

The issue is that portions of a data package may be archived resulting in an undefined state. For example, a resource map may be archived. Under the new proposal it will be indexed and so the package exists in the index, though this may be contrary to the intent which might have been to dissociate the data object from the metadata.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)