Project

General

Profile

Bug #2977

ONEMercury Member Node filter disappearing from query on some actions

Added by Skye Roseboom almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Skye Roseboom
Category:
d1_mercury
Start date:
2012-06-19
Due date:
% Done:

100%

Estimated time:
3.00 h
Milestone:
CCI-1.0.2
Product Version:
*
Story Points:
Sprint:

Description

Observed two conditions where this occurs:

1 - From search UI select a Member Node and search on '*'. On search results add a filter - Member Node filter disappears from query string although the filter string still thinks its filtering.

2 - From search UI just do * search. From search results filter on a MN. Filter on anything else. Using the 'remove' link in the filter string - remove the non-MN filter item. MN filter disappears from query, remains in filter string.

So we seem to be losing the MN filter value somewhere in the navigation between query actions (adding filter in first example, removing filter in second). Hopefully just a javscript fix - but possible it may require an update to the spring mvc controller component.

Should be an easy fix. 1-3 hours likely.

redmine2977.patch Magnifier (7.22 KB) Skye Roseboom, 2012-06-21 19:31

History

#1 Updated by Skye Roseboom almost 9 years ago

  • Milestone changed from CCI-1.0.2 to CCI-1.1

#2 Updated by Skye Roseboom almost 9 years ago

  • Milestone changed from CCI-1.1 to CCI-1.0.2

#3 Updated by Skye Roseboom almost 9 years ago

  • Status changed from New to In Progress

#4 Updated by Skye Roseboom almost 9 years ago

Looks like this issue originates from the original mercury product as I can reproduce this issue on http://mercury.ornl.gov/ornldaac/

#5 Updated by Skye Roseboom almost 9 years ago

After inspecting the generated URLs for the 'remove' actions, it appears they are correct - they contain the datasource facet and facet attribute values.

Maybe getting lost in the SolrClientController or SolrTransactionService somewhere?

#6 Updated by Skye Roseboom almost 9 years ago

patch file to address disappearing MN. Issue in 'remove facet' logic was clearing the datasource filter anytime a facet filter was removed from query.

#7 Updated by Skye Roseboom almost 9 years ago

placed on 1.0 branch for release in 1.0.2 branch.

Need to create a 1.0.1 tag for d1_mercury_common project for use in the 1.0.2 patch release.

#8 Updated by Skye Roseboom almost 9 years ago

Copied to 1.0.0 branch for release in 1.0.2 patch

#9 Updated by Skye Roseboom almost 9 years ago

  • Position changed from 1 to 471
  • Position set to 1
  • Target version changed from Sprint-2012.25-Block.4.1 to Sprint-2012.27-Block.4.2

#10 Updated by Skye Roseboom almost 9 years ago

  • Position deleted (473)
  • Position set to 17

#11 Updated by Skye Roseboom almost 9 years ago

  • Status changed from In Progress to Closed

tested with 1.0.2 patch release on sandbox.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)