Project

General

Profile

Bug #2976

ONEMercury 'Author' filter not working on single names.

Added by Skye Roseboom almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Skye Roseboom
Category:
d1_mercury
Start date:
2012-06-19
Due date:
% Done:

100%

Milestone:
CCI-1.0.2
Product Version:
*
Story Points:
Sprint:

Description

In production and stage, using an 'author' filter that is just a single name - 'Higgins', 'Kruger' - will not return any results. However the presence of these values in the filter control indicates there should be. Does not seem to effect complex names, for example on on-stage the author filter value 'CDEC California Data Exchange Center' works with no issues.

Unclear if the filter value itself is erroneous or if its the filter query at issue.

To reproduce, search on *. Find an author filter value with single word value like 'SANSPark' and click it. No results.

redmine2976.patch Magnifier (5.89 KB) Skye Roseboom, 2012-06-25 23:27

History

#1 Updated by Skye Roseboom almost 9 years ago

  • Milestone changed from CCI-1.1 to CCI-1.0.2

#2 Updated by Skye Roseboom almost 9 years ago

  • Status changed from New to In Progress

#3 Updated by Skye Roseboom almost 9 years ago

Single name author fields have a hardcoded " " (space) character present - to separate surname(space)givenName. However this space is present even when only a surname is provided.

Tested by searching on 'Higgins ' or 'Gibler ' and get results where searching on 'Higgins' does not return results.

Since the facet is building properly from the author value - we are losing the space in the query building.

Other possible solution is to trim the extra space from the author field when only a surname is present.

#4 Updated by Skye Roseboom almost 9 years ago

Identified path through SolrField where trailing whitespace from author with just surname is provided was not being removed.

Fix committed to trunk for testing. Then will need to be moved to 1.0 branch for 1.0.2 patch release.

#5 Updated by Skye Roseboom almost 9 years ago

attaching file that fixes issue where simple xpath concat expression breaks when a 'creator' is defined with only a 'surname' (no firstName). XPath happily just finds the first element found and concats it with the first found regardless if they are different root elements.

Replaced with usage of the CommonRootSolrField which respects the concept of a common parent/root element (creator).

#6 Updated by Skye Roseboom almost 9 years ago

  • Position changed from 1 to 472
  • Target version changed from Sprint-2012.25-Block.4.1 to Sprint-2012.27-Block.4.2
  • Position set to 1

#7 Updated by Skye Roseboom almost 9 years ago

  • Position set to 22
  • Position deleted (473)

#8 Updated by Skye Roseboom almost 9 years ago

  • Status changed from In Progress to Closed

tested with 1.0.2 patch release on sandbox.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)