Project

General

Profile

Task #168

Common tools and APIs in CN proto server

Added by Giri Palanisamy over 12 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Milestone:
None
Product Version:
*
Story Points:
Sprint:

Description

We are preparing Mercury package for the CN. Mercury needs MySQL, JVM 1.6, tomcat 5.5 or greater. Can we have a common implementation of the above? so that Metacat, Mercury and other tools can use the same installation?

thanks!

History

#1 Updated by Robert Waltz over 12 years ago

Are there any constraints that would restrict from going with Tomcat 6?

#2 Updated by Dave Vieglais over 12 years ago

WRT existing dependencies, they may be filled by other apps installed on the system, but you should still list the dependencies as illustrated in the metacat metapackage at source:/software/cicore/trunk/cn-buildout/dataone-cn-metacat/DEBIAN/control

The idea is that the Mercury package should be installable without consideration of other apps that may or may not be installed on the machine. dpkg should work out whether it needs to install additional stuff to support the app (e.g. if the deps have already been installed)

Since Tomcat6 is listed as a dependency for Metacat, it would be really good if Mercury could use that version as well - otherwise installation will be ugly.

#3 Updated by Dave Vieglais over 12 years ago

  • Status changed from New to Closed

Closing as this ticket is a dupe of #81, and overlaps with #166.

#4 Updated by Giri Palanisamy over 12 years ago

Sure, I will prepare the dependencies list for the latest Mercury version.

Yes - Mercury can be deployed in Tomcat 6.0. The other two common packages that Metacat and Mercury can share are JVM 1.6 and [MySQL].

#5 Updated by Matthew Jones over 12 years ago

Metacat doesn't use MySQL -- it uses Postgresql or oracle. I've got the dependencies set up to use postgres right now. I am currently working on the postinst script for the metacat deb package to make it automatically install everything.

When you are setting up the dependencies for Mercury, please be sure to NOT install gcj -- it is a horrible nuisance. I notice, for example, that ant has a gcj dependency, so I opted to not install ant via the deb package system.

I'll be doing another big checkin for metacat soon.

#6 Updated by Giri Palanisamy over 12 years ago

Thanks, I will make a note on the gcj. for the initial setup, we will probably install the MySQL as a separate installation (not part of Mercury deployment package).

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)