Project

General

Profile

Task #1437

Story #1432: New functionality that depends on authn/authz infrastructure.

Add filtering by requestor in /monitor/object collection.

Added by Roger Dahl over 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
d1_libclient_python
Target version:
Start date:
2011-03-25
Due date:
% Done:

100%

Milestone:
None
Product Version:
*
Story Points:
Sprint:

Description

getObjectStatistics currently does not support filtering by principal. Filtering by principal would enable a user to get stats only about his own objects.

Need to be determined:

  • Do we want a client to be able to connect directly to a MN to retrieve stats? The issue is that with objects being replicated to multiple servers, such stats will be incomplete. The only way to get complete stats is either to have the client connect to each MN in turn and aggregate the results or having a CN pull the stats and do the aggregation. If we do the latter, then we don't need any searching/filtering on the monitoring collections.

History

#1 Updated by Roger Dahl almost 11 years ago

  • Status changed from New to Closed
  • Milestone set to None

Not in spec for v1.

#2 Updated by Roger Dahl almost 11 years ago

  • Target version changed from Sprint-2011.27-Block.4 to Sprint-2011.34-Block.5

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 14.8 MB)